Makefile do Linux para verificar a versão mínima necessária do kernel do Linux

Eu tenho um makefile Linux que precisa compilar em duas versões diferentes do kernel. O makefile não é gerado a partir do automake/autoconf.

O código C já está condicionado usando macros para gerar código diferente para a versão do kernel diferente, mas certos recursos no makefile também precisam ser condicionados.

Existe uma maneira de fazer um makefile:

if (kernel_version > 2.6.30)
    newer_kernel = 1
else
    newer_kernel = 0
endif
0

Não há respostas.

0
Brasil Linux
Brasil Linux
2 873 dos participantes

O primeiro e grande grupo sobre LINUX do Telegram, que temos como base o S.O. GNU/Linux, que vai de usuários iniciantes / avançados! Vejam nossos parceiros: http://urele.com/parceiros Desde: 16/11/2015

Técnicos em Informática
Técnicos em Informática
2 517 dos participantes

Um grupo com foco em assuntos técnicos, hardware, servidores e resolução de problemas em Windows e Linux. Canal: @dicasdeti

Linux
Linux
1 950 dos participantes

Grupo focado para compartilhar conhecimentos e tirar dúvidas sobre Linux + LPIC.Proibido a divulgação de materiais copyright e pirataria.Bot: @GrupoLinuxbot . Link: https://goo.gl/KQYqhN Steam: https://goo.gl/KgQ0yH Estatísticas: https://goo.gl/Ld1BKM

SysAdmin Brasil Linux
SysAdmin Brasil Linux
320 dos participantes

Sysadmin é o profissional responsável pelo ambiente de TI de uma organização. Isso normalmente compreende servidores, equipamentos de rede, acesso à Internet, serviços ao usuário, banco de dados, segurança e outros. Grupo parceiro: @BrasilLinux 23/06/17