Problemas com a instalação do Visual Studio Express

Acabei de instalar 'Visual C# 2008 Express Edition' e 'Visual Web Developer 2008 Express Edition' na minha máquina Vista. Anteriormente eu tenho executado estes no Win XP. Ao iniciar o software, iniciar um novo projeto e tentar construí-lo, recebo avisos como "O componente referenciado 'Sistema' não pôde ser encontrado."; uma linha para cada namespace usado. Eu tenho o .NET Framework 3.5 instalado e são capazes de navegar pelas guias em 'Adicionar referência', mas não consigo fazê-lo funcionar. (A reinstalação não ajudou.) Existe uma solução fácil?

0
adicionado editado
Visualizações: 1
Você está executando como administrador? (Clique com o botão direito no menu de contexto no exe)
adicionado o autor Thomas Wagner, fonte

4 Respostas

Você está lançando via "Run As Administrator"? É possível que as permissões em seus diretórios do framework .Net não sejam o que deveriam ser.

0
adicionado

Eu realmente não queria seguir a resposta aceita e fazer uma instalação limpa. Uma solução melhor que recebi dos fóruns do MSDN:

Go to Control Panel > Programs and Features > Turn Windows Features on or off...

Then enable everything under Microsoft .Net Framework 3.0

0
adicionado

Problema resolvido. Eu usei a solução mais radical que eu poderia criar - uma instalação limpa do Vista. De alguma forma, reinstalar o Visual Studio não inclui todas as etapas essenciais. A primeira vez que o software é lançado, ele se configura. Algo deve ter dado errado na primeira vez e quando o procedimento foi feito novamente, ele tentou usar a configuração "quebrada". Bem, agora está consertado.

0
adicionado

Você tem algum patch ou atualização que possa haver para esse software? O outro pensamento seria copiar o System.dll para a pasta bin do projeto, que é o que eu costumava fazer em projetos anteriores para fazer as coisas funcionarem.

0
adicionado